A simple menu for the gallery has been added: Menu for Gallery

Edelbrock Quicksilver Caburator

Forum rules
Please do not start new topics here, but here: New Panhead and Flathead topics
Post Reply

Edelbrock Quicksilver Caburator


Post by CayB » Thu Aug 09, 2007 12:27 pm

Hi forum. I have a older Edelbrock quicksilver cab on my 63 Panhead. I have chance the nedels in all different sizes but stil it shoots form the cab when the engine is cold and even when its hot. Is Edelbrock just a bad choice!? ore is there some trick, if it aint the nedel??? Some one told me that with a S&S all my troubel would be gone... That cab is the best working for my daily ride. I know Linkert is nice but its not the thing for me.. sorry. Best Cay

Posts: 230
Joined: Tue Aug 10, 2004 5:11 pm
Location: Michigan, USA


Post by 57pan » Thu Aug 09, 2007 1:35 pm

I don't have any experience with the Edelbrock carb but, generally, if you are backfiring thru the carb it is a sign that it is running too lean. Whenever you have a lean condition you need to pressure test the manifold to make sure it is not sucking air in where the O-rings seal the manifold to the heads. Well, actually, it's a good idea to pressure test the manifold anyway - before making ANY other changes.

Also, look at the plugs. If one of them is almost white and the other is much darker, that is almost a sure sign that you have a manifold leak somewhere, or even a head gasket leak (as I found when I removed my heads last fall because the plugs were uneven).

Posts: 1390
Joined: Mon Apr 11, 2005 1:12 pm
Location: north florida


Post by fourthgear » Thu Aug 09, 2007 10:02 pm

Could be timing or lifter adjustment also and hows the battery?

Post Reply

Return to “Carburetor/Fuel system”