Generator/regulator: having problems with charging system

Electrical issues
Forum rules
Please do not start new topics here, but here: New Panhead and Flathead topics
Post Reply
biff
Posts: 3
Joined: Fri Jul 13, 2007 1:13 pm

Generator/regulator: having problems with charging system

#1

Post by biff » Thu Jul 14, 2005 6:50 am

Hopefully some can help me. I have a stock 54 pan converted to 12 volt. I'm running a Bosch style generator with harley 65 generator. I was having problems with the charging system so I bought a new Accel Bosch style regulator. I decided to have the generator checked at the same time. The shop informed me the armature was fried so I bought a new generator from Cycle Shack. I made sure I polarized it. Bike now has some miss firing, generator light dims when revving but never goes completely out. Also gen light seems to pulsate to engine when idling. Maybe I need to make sure I wired the regulator properly. B+ to battery obviously, DF to F on generator, D+ to A on generator, ground to a ground. The guy I bought the bike from is using a stock wiring harness, one wire from this harness comes from dash(probably to gen light) hooked up to DF terminal.I left that wire there & hooked another wire from DF to F on gen. Is it wired correctly or can anyone think of anything I"m missing? Battery has full charge.



Cotten
Posts: 6791
Joined: Mon Aug 26, 2002 9:09 am
Location: Central Illinois

Re: Generator/regulator

#2

Post by Cotten » Thu Jul 14, 2005 12:05 pm

Try wiring the generator light to the armature terminal instead.

And you would be wise to have the regulator and generator re-tested.

I have good luck with Argentinian Bosches and generics when used with a CE generator and sportster battery on Chiefs, but they do not have the oiltank heat concern.

If possible, you may want your regulator adjusted for your application, in order to extend your battery's life.

Beware also, that if your original generator was a true Model 65, your replacement will have the terminals switched opposite to a Model 65a conformity.

(And save me your "worthless" core!)

fourthgear
Posts: 1365
Joined: Mon Apr 11, 2005 1:12 pm
Location: north florida

Re: Generator/regulator

#3

Post by fourthgear » Thu Jul 14, 2005 4:45 pm

Hay Cotton, I like that WORTHLESS core comment.

biff
Posts: 3
Joined: Fri Jul 13, 2007 1:13 pm

Re: Generator/regulator

#4

Post by biff » Thu Jul 14, 2005 6:33 pm

I never said or implied that the original generator was worthless. I have the original and will rebuild it in time. The new generator is not an import and is made in the USA by the same company that made them originally for Harley. I bought new one so I could be back on the road right away.

fourthgear
Posts: 1365
Joined: Mon Apr 11, 2005 1:12 pm
Location: north florida

Re: Generator/regulator

#5

Post by fourthgear » Thu Jul 14, 2005 7:46 pm

Sorry Biff , it was some comic relief on my part . We all know the core of anything Org. on an HD is worth a lot.

biff
Posts: 3
Joined: Fri Jul 13, 2007 1:13 pm

Re: Generator/regulator

#6

Post by biff » Thu Jul 14, 2005 8:49 pm

Hello Cotton,
I switched wire for gen light to armature and it works properly. The new generator is a CE, I don't know where or how I came up with Cycle Shack(late nite). My original gen is a true model 65 at least according to the housing. You mentioned that the new one will have the terminals switched opposite to a Model 65a conformity. If this is the case can you tell me the proper wiring? I'm going to test the gen & reg tonite.
Many thanks again


update
Checked generator & regulator today, both are working & charging battery.

Post Reply

Return to “Electrical”