65 electraglide electric problems

Electrical issues
Forum rules
Please do not start new topics here, but here: New Panhead and Flathead topics
Post Reply
windyhilldavey
Posts: 4
Joined: Thu Jun 23, 2011 10:31 pm
Bikes: Panheads
Has thanked: 8 times

65 electraglide electric problems

#1

Post by windyhilldavey » Fri Jul 01, 2011 8:13 pm

My 1965 electraglide is freshly restored( built from a motor up) I am having trouble with the electrical. Every once in awhile the bike loses all power and dies. usually when I come to a stop sign or am pulling in to a parking lot. I can wiggle the ignition switch and that does not seem to matter. After a few seconds of frantically looking but not finding a problem ,the juice comes back on and i can start it up and ride away.I have pulled the generator and had it tested, it is very good.
any idea's?

thanks.
Davey



Cotten
Posts: 6911
Joined: Mon Aug 26, 2002 9:09 am
Location: Central Illinois
Has thanked: 100 times
Been thanked: 268 times

Re: 65 electraglide electric problems

#2

Post by Cotten » Fri Jul 01, 2011 8:49 pm

Davey!

Did you install a 'modern' circuit breaker in the positive battery lead?

That would explain the return of 'juice', but not the ultimate cause of the problem.

....Cotten

Robert Luland
Posts: 899
Joined: Sun Sep 02, 2007 7:56 pm
Bikes: 1922JD, 1937 ULH, 1946FL 1948FL, 1957FL, 1960FLH, 1965XLCH, 1995 FLHT
Location: Hoboken, NJ
Been thanked: 36 times
Contact:

Re: 65 electraglide electric problems

#3

Post by Robert Luland » Fri Jul 01, 2011 10:10 pm

Davey, Let us explore this problem. It's obvious that you have a short which is tripping the circuit breaker as Tom pointed out. According to your post it happens when your stopping at a light or parking lot. And what are ya doing at that point in time? Your applying the brake. I think ya might have all ready partially solved your problem. Check the rear brake light wiring. Bob

1950Panhead
Posts: 1628
Joined: Wed Jul 07, 2010 4:28 am
Bikes: 1950Panhead
Location: USA
Been thanked: 115 times

Re: 65 electraglide electric problems

#4

Post by 1950Panhead » Fri Jul 01, 2011 10:11 pm

And check the brake switch terminals for shorting on the brake housing.

fourthgear
Posts: 1391
Joined: Mon Apr 11, 2005 1:12 pm
Location: north florida
Been thanked: 4 times

Re: 65 electraglide electric problems

#5

Post by fourthgear » Sat Jul 02, 2011 2:15 am

If you have an auto reset breaker on the main power supply as was discribed above , they usually reset as soon as the short goes away .

Like if you have a short in the brake light circuit , press on the brake & it trips , let off the brake & breaker resets.

Pulling to a stop ,your gen. is putting out less voltage/amps & is relying on the batt. more , check to make sure your batt. is charged & charging.

windyhilldavey
Posts: 4
Joined: Thu Jun 23, 2011 10:31 pm
Bikes: Panheads
Has thanked: 8 times

Re: 65 electraglide electric problems

#6

Post by windyhilldavey » Sat Jul 02, 2011 4:28 pm

Thanks Guys
I will be checking it out Sunday morning.

Post Reply

Return to “Electrical”