Am I missing something?

Electrical issues
Forum rules
Please do not start new topics here, but here: New Panhead and Flathead topics
Post Reply
Guest

Am I missing something?

#1

Post by Guest » Thu Apr 20, 2006 12:55 pm

Trying to fit a '65-later 12 volt regulator to a '60 pan. The regulator is longer and has two mounting holes at the top, where the 6 volt regulator has only one. Am I missing a part?
TIA



Cotten
Posts: 6911
Joined: Mon Aug 26, 2002 9:09 am
Location: Central Illinois
Has thanked: 100 times
Been thanked: 268 times

#2

Post by Cotten » Thu Apr 20, 2006 1:05 pm

Guest!

I don't believe the MoCo ever made a bracket to install the larger regulator on earlier models.

You will have to be creative.

....Cotten

VPH-D
Posts: 867
Joined: Tue Feb 01, 2005 1:00 am
Been thanked: 58 times

#3

Post by VPH-D » Thu Apr 20, 2006 3:38 pm

You need to use an XLCH type Bosch regulator, or a solid state type.
The solid state type might fit on the motor mount type bracket, but the Bosch type won't. When using the Bosch type, get one of those aftermarket mounts that fit on the end of the generator. Wire it up like 60s XLCH, and check your battery water level often.
VPH-D

johnny_redneck
Posts: 1
Joined: Thu Apr 20, 2006 12:51 pm

#4

Post by johnny_redneck » Thu Apr 20, 2006 6:53 pm

Thanks for the quick replies Cotten & VPH-D.
Cotten, you going to Oley?

Cotten
Posts: 6911
Joined: Mon Aug 26, 2002 9:09 am
Location: Central Illinois
Has thanked: 100 times
Been thanked: 268 times

#5

Post by Cotten » Fri Apr 21, 2006 3:11 am

Regretfully, D-port is the only Meet I can attend.

...Cotten

Post Reply

Return to “Electrical”