59 pan clutch release arm & clutch lever problem

Post Reply
neilw
Posts: 233
Joined: Sat Dec 20, 2008 3:24 am
Bikes: 1995 Roadking(still brand new)
1991 HD springer
1959 pan (I'm reassembling)
1978 BMW R100RS
Location: Calgary
Been thanked: 2 times

59 pan clutch release arm & clutch lever problem

#1

Post by neilw » Thu Apr 19, 2012 4:21 am

My bell crank assembly is is place ,so is my clutch release arm. They both have a great deal of return pressure. BUT once I attach the rod that joins them I have no return pressure ,nothing is rubbing or in any way obstructing the movement of the rod . The only thing I notice is the end of the rod that goes into the clutch release arm seems to bind. It doesnt make sense that it binds that bad that it restricts movement. I wonder if the rod or hole in the release arm is worn . I'm attaching a photo of each . Keep in mind the clutch release arm has so much pressure that it is hurting my palm when I push it forward ,and the bell crank has the same amount of pressure ,that is until I join them together with the rod , then I have to help them to return. Thanks , Neil
You do not have the required permissions to view the files attached to this post.



RUBONE
Moderator
Posts: 5054
Joined: Sat Nov 15, 2008 4:09 am
Bikes: Multiple H-D, Ducati, BMW, Triumph, BSA,...
Has thanked: 11 times
Been thanked: 486 times

Re: 59 pan clutch release arm & clutch lever problem

#2

Post by RUBONE » Thu Apr 19, 2012 4:28 am

Neil,
It sounds like your mousetrap is not adjusted correctly. Do you have a factory service manual? It has very good instructions on how to adjust it. If it is wrong it will not return!
Robbie

beets
Posts: 114
Joined: Fri Jul 13, 2007 1:03 pm
Bikes: 56 FL, 07 Goldwing ,91 BMW K75
Been thanked: 2 times

Re: 59 pan clutch release arm & clutch lever problem

#3

Post by beets » Thu Apr 19, 2012 4:51 am

Could your system be aftermarket? I saw an aftermarket clutch lever that had the slot cut at the wrong angle and it would bind.

neilw
Posts: 233
Joined: Sat Dec 20, 2008 3:24 am
Bikes: 1995 Roadking(still brand new)
1991 HD springer
1959 pan (I'm reassembling)
1978 BMW R100RS
Location: Calgary
Been thanked: 2 times

Re: 59 pan clutch release arm & clutch lever problem

#4

Post by neilw » Thu Apr 19, 2012 5:36 am

Thanks you guys , I was ajusting things wrong and now have a good working clutch release set-up.
I'm sure glad I wasnt trying to figure this out on the side of trhe road.
Your right the manual has very good instructions ..
Neil

Post Reply

Return to “Clutch”