A simple menu for the gallery has been added: Menu for Gallery

Main shaft oil leak

Post Reply
Posts: 29
Joined: Fri Sep 12, 2014 10:12 am

Main shaft oil leak


Post by txpan49 » Thu Jan 22, 2009 5:07 pm

I just had my 49 totally rebuilt and got to put the first 10 miles on it. When I got back to the house there was oil dripping pretty steadily from the front of the primary area under the main shaft. I pulled the primary belt and inner primary to get a look at the seal. It is brand new but I did notice oil wetness around the outer edge of the seal where it seats in the left engine case. I called the mechanic that did the work and he mentioned that some seals are different size and the one he put in he felt was not as tight as he would have wanted. Honesty at least. I believe some oil is supposed to get through right? Is there anyway to seal this better? I am thinking about ordering another seal.

Posts: 6911
Joined: Mon Aug 26, 2002 9:09 am
Location: Central Illinois

Re: Main shaft oil leak


Post by Cotten » Thu Jan 22, 2009 6:21 pm

Before you throw blame or money anywhere, drain the tranny and fill it with mineral spirits or kerosene. Then you can observe exactly where the leakage occurs.
This may make life easier with your mechanic, as well as saving you money in the long run.


Posts: 1003
Joined: Tue Mar 16, 2004 5:52 am
Location: Sultan, WASH

Re: Main shaft oil leak


Post by mbskeam » Thu Jan 22, 2009 11:11 pm

is this a oem style or the colony with the seal in it?
on mine I put silicone on the outside edge into the area that has the snap ring, this has stoped any weeps that might find there way out. I just cleaned it real good with lacquer thiner and Q-tips until they stayed white then put a bead into the groove, let it sit over night and put it back together,
you might try this, it cant hurt.
but if you let oil leaks drive you nuts you will end up like me.........
I feel much better now....


Posts: 29
Joined: Fri Sep 12, 2014 10:12 am

Re: Main shaft oil leak


Post by txpan49 » Fri Jan 23, 2009 3:55 pm

Cotton, I am sorry I am not very descriptive in my post but I meant the engine shaft. And sorry about the honesty comment, he is a darn good mechanic. My comment was that he told me immediately and helped me narrow down the symptoms.
Mbskeam, thanks I was going to ask about putting some sealer on there. I am not sure if it is a Colony but yes it has the seal and retainer ring. I am thinking about ordering a new one from JP to see if there might be an O.D. difference. The oil seams to be coming from the outer most edge where I believe it is metal to metal fitment.
I have not checked the oil pressure. I am wondering if perhaps it could be too high. Do you think that could cause an steady leak? I am not concerned about a small leak but the steady drip has me concerned.

Posts: 1390
Joined: Mon Apr 11, 2005 1:12 pm
Location: north florida

Re: Main shaft oil leak


Post by fourthgear » Fri Jan 23, 2009 6:32 pm

You might want to make sure you breather is venting correctly , you did mention you had a belt drive , some people plug it up or inadvertently cause a restriction and that can cause all kinds of problems with oil blow by.

Post Reply

Return to “Transmission, Starter & Shifting”