quick start 2000 elect. ignit.

All ignition related articles
Post Reply
Billpan58
Posts: 113
Joined: Mon Jul 19, 2010 2:36 pm
Bikes: 58FL 99M2Buell 89Sporty
Location: Sanford,mi.

quick start 2000 elect. ignit.

#1

Post by Billpan58 » Sun Sep 05, 2010 4:39 pm

any one else installed this on their single point 6 volt pan. recently added it have not changed the timing,bike fired right up after install,but you can't retard it as far as i could w/points.seems like there is a smaller area between advanced and retard. any feed back would be appreciated. bike seems to run down the road fine, still getting used to the screaming eagle carb we added also. also put on new rear chain and rear sprocket. Learned one thing about those oring [old one] chains don't assume they are in good shape just because they look nice on the outside,when i removed the master link the inner pins were all rusty,i have been using pj1 [ does'nt seem to penetrate] will be using something less tacky.



james
Posts: 832
Joined: Tue Nov 18, 2008 7:33 pm
Bikes: 2003 FLHRCI
1952 FL
Location: Wrightsville Pennsylvania

Re: quick start 2000 elect. ignit.

#2

Post by james » Sun Sep 05, 2010 6:40 pm

I installed the Quick Start 2000 in my 52 and it works just fine. Can retard ignition just like it had points. I would double check your timer adjusting plate and stud or cable adjustment since you had to remove the timer top to install the Quickstart, maybe something is out of wack.

What is a wack anyway?

jim

Post Reply

Return to “Ignition”